IPv4 的 DHCP 选项
功能简介
话机可以通过DHCP选项在IPv4网络中获取与IPv4相关的参数。
有关DHCP选项的更多信息,请参阅 RFC 2131 或 RFC 2132。
支持的IPv4 DHCP选项
下表列出了Yealink话机支持的常见IPv4 DHCP选项。
DHCP 选项 参数 描述
1 子网掩码 指定客户端的子网掩码。
2 时间偏移 指定客户端子网相对于协调世界时(UTC)的偏移量(以秒为单位)。
3 路由器 指定客户端子网上路由器的IP地址列表。
4 时间服务器 指定可用给客户端的时间服务器列表。
6 域名服务器 指定可用给客户端的域名服务器列表。
7 日志服务器 指定可用给客户端的MIT-LCS UDP服务器列表。
12 主机名 指定客户端的名称。
15 域名服务器 指定客户端在通过DNS解析主机名时应使用的域名。
28 广播地址 指定客户端子网中使用的广播地址。
42 网络时间协议服务器 指定可用给客户端的NTP服务器的IP地址列表。
43 供应商特定信息 标识供应商特定信息。
60 供应商类标识符 标识供应商类型。
66 TFTP服务器名称 标识TFTP服务器,当DHCP头中的sname字段已用于DHCP选项时。
DHCP选项160和选项161
Yealink Zoom设备支持在启动时通过检测DHCP自定义选项来获取配置服务器地址。如果DHCP选项66不可用,可以使用自定义选项(160或161)与配置服务器的URL或IP地址。设备将自动检测选项160或161以获取配置服务器地址。
要使用DHCP选项160或选项161,请确保启用了DHCP激活功能并配置了自定义选项。
下表列出了可用于配置DHCP选项160或161的参数。
static.auto_provision.dhcp_option.enable
static.auto_provision.dhcp_option.list_user_options
参数 允许值 描述
static.auto_provision.dhcp_option.enable[1] 0-关闭1(默认)-开启 触发DHCP选项功能的开启或关闭。
static.auto_provision.dhcp_option.list_user_options[1] 128到254之间的整数 配置用于请求配置服务器地址的自定义DHCP选项。多个DHCP选项用逗号分隔。 注意 仅当 static.auto_provision.dhcp_option.enable 设置为1(开启)时有效。
DHCP选项66、选项43和自定义选项
在启动期间,设备将自动检测自定义选项、选项66或选项43以获取配置服务器地址。
优先级如下:自定义选项 > 选项66(标识TFTP服务器)> 选项43。
话机可以通过检测选项43在启动期间获取自动配置服务器(ACS)地址。
要通过DHCP选项获取服务器地址,请确保已在设备上配置DHCP选项。该选项必须与DHCP服务器中定义的选项一致。
如果无法在DHCP服务器上配置用于发现配置服务器的DHCP选项,则需要自动发现配置服务器地址的替代方法。一种可能性是连接到响应DHCP INFORM查询并提供请求的配置服务器地址的备用DHCP服务器。有关更多信息,请参阅RFC 3925。
如果单个备用DHCP服务器响应,这在功能上等同于主要DHCP服务器响应有效的配置服务器地址。如果没有DHCP服务器响应,INFORM查询过程将重试,直到超时。
DHCP选项42和选项2
Yealink话机支持使用DHCP提供的NTP服务器地址。
DHCP选项42用于指定可用给客户端的NTP服务器的IP地址列表。NTP服务器应按优先级顺序列出。
DHCP选项2用于指定客户端子网相对于协调世界时(UTC)的偏移量(以秒为单位)。
DHCP选项12
使用DHCP时,你可以为话机指定主机名。DHCP客户端使用选项12向DHCP注册服务器发送预定义的主机名。该名称可以包含本地域名,也可以不包含(基于 RFC 2132)。
有关字符集限制,请参阅 RFC 1035。
下表列出了可用于配置DHCP选项12的参数。
static.network.dhcp_host_name
参数 允许值 描述
static.network.dhcp_host_name[1] 最多99个字符的字符串 使用DHCP时为话机指定主机名。
[1] 如果更改此参数,话机将重新启动以使更改生效。
DHCP选项60
DHCP选项60用于指示DHCP客户端的供应商类型和功能。你可以设置选项60的格式。默认的供应商类ID是 yealink。
通过网页用户界面配置DHCP选项60
以管理员身份登录话机的网页界面。
在空闲界⾯,按 设置 > 自动更新 > DHCP选项值。
image.png
通过自动配置配置DHCP选项60
static.auto_provision.dhcp_option.option60_value
参数 允许值 描述
static.auto_provision.dhcp_option.option60_value 最多99个字符的字符串 配置在DHCP交互中使用的供应商类标识符字符串。
IPv6 的 DHCP 选项
功能简介
Zoom设备可以通过DHCP选项在IPv6网络中获取与IPv6相关的参数。
下表列出了Yealink Zoom设备支持的常见IPv6 DHCP选项。
DHCPv6 选项 参数 描述
23 DNS服务器 指定可用给客户端的DNS服务器列表。
24 DNS域搜索列表 指定给客户端的域搜索列表。
31 SNTP服务器 指定可用给客户端的简单网络时间协议(SNTP)服务器列表。
32 信息刷新时间 指定客户端在刷新从DHCPv6获取的信息之前应等待的上限时间。
这些选项帮助设备在IPv6网络中自动获取必要的网络配置信息,以确保设备能够正确连接和使用网络资源。